Intel HDMI Display Audio 44.1Khz issue – No Bitperfect CD Audio

As far as I can tell the Intel Display Audio HDMI driver does not support 44.1Khz bitperfect passthrough to my receiver, and it looks like an issue Intel have ignored for a long time.

Equipment:

  • Gigabyte Brix BXBT-1900 (Intel Celeron J1900, Intel HD Graphics)
  • Windows 10 Pro
  • Kodi 3D MVC Build
  • Pioneer VSX-S510K Receiver
  • LG 49UB850V 49″ 4K 3D TV

Test 1

In Kodi, set the audio output for system as WASAPI (Receiver Name), and passthrough as WASAPI (Receiver Name), also tried connected directly to TV with HDMI.

Play a 16/44.1 or 24/44.1 FLAC, no sound output.

Play a 16/48 or 24/48, 24/96 etc, sound is output to receiver

Test 2

Using Foobar2000 with WASAPI

Play a 16/44.1 or 24/44.1 FLAC, no sound output.
(if a DSP for resampling is added to the output and set to 48000, sound is output).

Play a 16/48 or 24/48, 24/96 etc, sound is output to receiver.

Test 3

If the test button is pressed in Windows Speaker Properties dialog and audio is set to either 16/44.1 or 24/44.1 no sound is played when the test button is pressed

Links to reports of the same issue:

This one dates back to 2012, the potential fix at the end of the thread (2014) did not work for me, plus HD formats are not supported with it.
https://communities.intel.com/thread/32935?start=0&tstart=0

I will report any findings here.  Please let me know in the comments if you have this issue.

Workaround 1

In Intel graphics properties change refresh rate to 1920 x 1080 / 30p.  This works fine for me as I use my machine exclusively for Kodi.  As soon as this change was made foobar2000 could play my 44.1Khz flacs and checked that no system sounds could be heard and system volume control makes no difference.

Update (12 Jun 2016)

This issue might be related to a Intel HDMI incompatibility with my AV Receiver (and other models with this issue)

I have just upgraded it to a Marantz NR-1606 Slimline Receiver and this issue does not exist, WASAPI bitperfect sound is passed at any refresh rate.

Please post model numbers with this issue in the comments, other AVRs mentioned in Intel thread with potentially the same issue are:

Pioneer SC-LX-76

Pioneer SC-LX77

Kenwood RV-7000

Pioneer VSX-923

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s